Partial Network Outage

Incident Report for Utah Valley University

Resolved

The network outage affecting UVU Lehi campus has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Jun 26, 2025 - 20:31 MDT

Investigating

We are investigating reports of a network outage affecting UVU Lehi campus. Updates will be provided as we learn more.
Posted Jun 26, 2025 - 16:44 MDT
This incident affected: Network & Wireless (Wireless Network, Wired Network).