Partial MyUVU Outage

Incident Report for Utah Valley University

Resolved

The MyUVU outage affecting all users has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Nov 29, 2023 - 14:44 MST

Monitoring

A fix has been applied and MyUVU should be available to all users. We will continue to monitor MyUVU closely.
Posted Nov 29, 2023 - 12:51 MST

Investigating

We are investigating reports of a MyUVU outage. Updates will be provided as we learn more.
Posted Nov 29, 2023 - 12:21 MST
This incident affected: myUVU Services (myUVU General Services, myUVU Student Services, myUVU Employee Services).