Get email notifications whenever Utah Valley University creates, updates or resolves an incident.
Get text message notifications whenever Utah Valley University creates or resolves an incident.
Get webhook notifications whenever Utah Valley University creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 29, 2024 - 17:30 MDT
Scheduled
Adobe products used at UVU will undergo some maintenance from 5:30pm to6:30 pm on August 29, 2024. If any product interruptions occur, please wait until after 6:30pm to try again or report the issue if it persists.
Posted Aug 27, 2024 - 15:46 MDT
This scheduled maintenance affected: Software, Websites & Apps (Adobe).