Bookmatch Outage
Incident Report for Utah Valley University
Resolved
The Bookmatch storefront outage has been resolved. Please contact the Service Desk if you experience further issues.
Posted Nov 07, 2024 - 10:21 MST
Identified
We have identified a Bookmatch storefront outage when using the Fall 2024 link on https://my.uvu.edu/student/bookmatch/
Updates will be provided as we learn more.
Posted Nov 05, 2024 - 09:28 MST
Investigating
We are investigating reports of a Bookmatch outage. Updates will be provided as we learn more.
Posted Nov 05, 2024 - 09:07 MST