Get email notifications whenever Utah Valley University creates, updates or resolves an incident.
Get text message notifications whenever Utah Valley University creates or resolves an incident.
Get webhook notifications whenever Utah Valley University creates an incident, updates an incident, resolves an incident or changes a component status.
The Box outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Aug 07, 2025 - 12:01 MDT
Update
The current outage is affecting users who rely on Box for collaboration. Most impacted users have already had their access to collaboration files restored. We are actively identifying any remaining affected users and working to reinstate their access as quickly as possible. If you experience any issues accessing collaboration files in Box, please reach out to the Service Desk for assistance.
Posted Aug 06, 2025 - 11:35 MDT
Identified
We have identified an issue preventing Box users from accessing files. Updates will be provided as we learn more.
Posted Aug 05, 2025 - 13:26 MDT
Investigating
We are investigating reports of Box being unavailable. It is being worked on. An update will be provided within the next hour.
Posted Aug 05, 2025 - 12:19 MDT
This incident affected: Storage, Servers, & Backups (Box).