Employee Email Partial Outage
Incident Report for Utah Valley University
Resolved
This incident has been resolved.
Posted Jul 02, 2020 - 20:04 MDT
Monitoring
The issue has been identified and a fix has been applied. Messages will be delivered as different sending services automatically retry them. We are continuing to monitor things closely.
Posted Jul 02, 2020 - 19:29 MDT
Identified
We have identified that employee email accounts currently cannot receive email from external senders. We are working to find a solution. An update will be provided when we have more information.
Posted Jul 02, 2020 - 17:16 MDT
Investigating
We have received reports that some email messages are not being delivered in the expected time and are looking into this issue. An update will be provided when we have more information.
Posted Jul 02, 2020 - 16:57 MDT
This incident affected: Email, Calendar, & Collaboration (Employee Email).