Financial Aid Upload Issue

Incident Report for Utah Valley University

Resolved

This incident has been resolved. Please contact the Service Desk if you continue to experience issues.
Posted Dec 02, 2024 - 09:50 MST

Update

If assistance is needed with uploading financial aid documents during the outage, please reach out to the service desk for assistance at 801-863-8888.
Posted Nov 22, 2024 - 12:05 MST

Identified

We have identified an outage affecting Financial aid services related to uploading documents. Updates will be provided as we learn more.
Posted Nov 22, 2024 - 11:50 MST

Investigating

We are investigating reports of financial aid upload being unavailable. Updates will be provided as we learn more.
Posted Nov 21, 2024 - 12:41 MST
This incident affected: myUVU Services (myUVU General Services, myUVU Student Services, myUVU Employee Services).