Windows Hello Pin Login Outage

Incident Report for Utah Valley University

Resolved

The Windows Hello PIN outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Jun 23, 2025 - 16:40 MDT

Identified

We’ve identified a Windows Hello outage affecting PIN login on Windows computers. A fix has been deployed, but it may take until the end of the day to fully sync. Users who need immediate access can contact their area techs to manually apply the fix.
Posted Jun 20, 2025 - 10:01 MDT

Investigating

We are investigating reports of a Windows Hello outage preventing pin login on Windows Computers. Updates will be provided as we learn more.
Posted Jun 20, 2025 - 09:35 MDT
This incident affected: General IT Services.