Concur Outage
Incident Report for Utah Valley University
Resolved
The Concur outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Sep 24, 2024 - 16:35 MDT
Monitoring
The reported Concur outage is resolved and Concur should be functioning as normal. We will continue to monitor closely.
Posted Sep 24, 2024 - 14:10 MDT
Identified
We have identified a service outage affecting Concur. Updates will be provided as we learn more.
Posted Sep 24, 2024 - 13:15 MDT
This incident affected: General IT Services.