Partial UVU Mobile App Outage

Incident Report for Utah Valley University

Resolved

The partial UVU Mobile App outage has been resolved. Please contact the Service Desk if you experience further issues.
Posted Jan 03, 2025 - 14:49 MST

Identified

We have identified a partial outage affecting the UVU mobile app. Closing and reopening or uninstalling and reinstalling the app may solve the issue. Updates will be provided as we learn more.
Posted Dec 19, 2024 - 10:18 MST
This incident affected: Software, Websites & Apps (myUVU).