Service Desk Phone Outage
Incident Report for Utah Valley University
Resolved
The phone outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Oct 24, 2024 - 17:47 MDT
Identified
We have identified a phone outage affecting inbound calls to the UVU Service Desk. If you need to contact the Service Desk, please contact them through chats or tickets found here: https://www.uvu.edu/servicedesk

Updates will be provided as we learn more.
Posted Oct 24, 2024 - 17:00 MDT
This incident affected: General IT Services.