Slow Performance with Canvas
Incident Report for Utah Valley University
Resolved
The issues affecting performance with Canvas has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Sep 26, 2022 - 09:46 MDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 26, 2022 - 09:41 MDT
Identified
We have identified a degraded performance issue with Canvas affecting students and faculty. Updates will be provided as we learn more.
Posted Sep 26, 2022 - 09:33 MDT
This incident affected: Teaching, Learning, & Classrooms (Canvas).