Partial myUVU Outage

Incident Report for Utah Valley University

Monitoring

A fix has been applied and new users should be able to have access granted to myUVU. We will continue to monitor myUVU closely.
Posted Aug 10, 2026 - 15:29 MDT

Identified

We have identified a partial myUVU outage affecting newly admitted students and employees access to myUVU. Updates will be provided as we learn more.
Posted Aug 10, 2026 - 10:36 MDT
This incident affects: myUVU Services (myUVU General Services).