myUVU Outage
Incident Report for Utah Valley University
Resolved
The myUVU outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Nov 12, 2024 - 08:33 MST
Identified
We have identified a myUVU outage affecting all users. Updates will be provided as we learn more.
Posted Nov 11, 2024 - 23:00 MST
This incident affected: myUVU Services (myUVU General Services, myUVU Student Services, myUVU Employee Services).