Partial my.uvu.edu outage
Incident Report for Utah Valley University
Resolved
This incident regarding my.uvu.edu has been resolved. Please contact the Service Desk if you continue to experience issues.
Posted Aug 22, 2021 - 10:55 MDT
Monitoring
A fix has been applied and my.uvu.edu logins should be available to users. We will continue to monitor it closely.
Posted Aug 20, 2021 - 09:49 MDT
Update
We are still investigating stability related to yesterday's outage of my.uvu.edu. We will know more as load and usage of the site increases during the day. Please call the service desk if you experience login failures with this service.
Posted Aug 19, 2021 - 12:24 MDT
Identified
We have identified a partial my.uvu.edu outage causing slowness and time out errors when logging in. Updates will be provided as we learn more.
Posted Aug 18, 2021 - 14:44 MDT
This incident affected: myUVU Services (myUVU General Services, myUVU Student Services, myUVU Employee Services).