Confluence Outage

Incident Report for Utah Valley University

Resolved

The Confluence outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Jun 16, 2026 - 12:41 MDT

Identified

We have identified a Confluence outage affecting all users. Updates will be provided as we learn more.
Please see the Atlassian Statuspage for details.
Posted Jun 16, 2026 - 08:10 MDT
This incident affected: Email, Calendar, & Collaboration (Atlassian).