Network Outage
Incident Report for Utah Valley University
Resolved
The network and myUVU outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Oct 21, 2024 - 20:27 MDT
Update
A fix has been applied and myUVU and campus internet should be available to all users. We will continue to monitor it closely.
Posted Oct 21, 2024 - 17:03 MDT
Identified
We have identified a network outage affecting access to UVU websites and internet on-campus. Updates will be provided as we learn more.
Posted Oct 21, 2024 - 16:41 MDT
This incident affected: myUVU Services (myUVU General Services) and Network & Wireless (Wireless Network, Wired Network).