Potential outage of network connectivity and multiple UVU services
Incident Report for Utah Valley University
Resolved
The network maintenance has been completed, and all UVU services and network connectivity should be functioning normally. Please contact the Service Desk if you encounter any issues.
Posted Sep 08, 2024 - 06:07 MDT
Identified
Network maintenance may result in outages impacting network connectivity and multiple UVU services. Updates will be provided as they become available.
Posted Sep 07, 2024 - 22:11 MDT
This incident affected: General IT Services.