Get email notifications whenever Utah Valley University creates, updates or resolves an incident.
Get text message notifications whenever Utah Valley University creates or resolves an incident.
Get webhook notifications whenever Utah Valley University creates an incident, updates an incident, resolves an incident or changes a component status.
The Wolverine Track outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Jun 24, 2025 - 08:53 MDT
Monitoring
A fix has been applied and Wolverine Track should be available. We will continue to monitor the service closely.
Posted Jun 23, 2025 - 16:35 MDT
Identified
Wolverine Track continues to have degraded performance. A support ticket has been submitted and we are waiting to hear back from Ellucian about the service.
Posted Jun 23, 2025 - 14:56 MDT
Monitoring
A fix has been applied and Wolverine Track should be available. We will continue to monitor the service closely.
Posted Jun 23, 2025 - 11:18 MDT
Identified
We have identified a Wolverine Track outage affecting all users. Updates will be provided as we learn more.
Posted Jun 23, 2025 - 09:58 MDT
Monitoring
A fix has been applied and Wolverine Track should be available. We will continue to monitor the service closely.
Posted Jun 23, 2025 - 09:22 MDT
Investigating
We are investigating reports of a Wolverine Track outage. Updates will be provided as we learn more.
Posted Jun 23, 2025 - 09:07 MDT
This incident affected: myUVU Services (myUVU Student Services).