Noorda Center Partial Power outage
Incident Report for Utah Valley University
Resolved
Power has been restored in the Noorda Center. Please contact the Service Desk if you are having any technical issues as a result of the power outage.
Posted Jan 31, 2020 - 19:24 MST
Identified
The Noorda Center is currently experiencing a partial power outage, UVU electricians are currently working to resolve the issues. We will update as we receive new information.
Posted Jan 31, 2020 - 19:00 MST