Service Desk call quality issue

Incident Report for Utah Valley University

Resolved

The Service desk call quality issue has been resolved. Please contact the Service Desk if you experience further issues.
Posted Mar 12, 2025 - 10:58 MDT

Monitoring

A fix has been applied and Service Desk call quality has been restored. We will continue to monitor the call quality closely.
Posted Mar 12, 2025 - 08:21 MDT

Investigating

We are investigating reports of poor call quality for users attempting to contact the Service Desk. More information will be provided as we learn more.
Posted Mar 11, 2025 - 17:50 MDT
This incident affected: General IT Services.