Recipients not receiving emails sent through the UVU directory page

Incident Report for Utah Valley University

Resolved

The issues affecting UVU directory emails has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Jul 15, 2025 - 16:47 MDT

Monitoring

A fix has been applied and emails sent through the UVU directory page should be functioning as expected. We will continue to monitor the affected services closely.
Posted Jul 15, 2025 - 15:34 MDT

Identified

We have identified further issues affecting emails sent through the UVU directory page. Updates will continue to be provided as we learn more.
Posted Jul 15, 2025 - 13:24 MDT

Monitoring

A fix has been applied and emails sent through the UVU directory page should be functioning as expected. We will continue to monitor the affected services closely.
Posted Jul 15, 2025 - 11:53 MDT

Investigating

We are investigating reports of users not receiving emails when sent through the UVU directory page. Updates will be provided as we learn more.
Posted Jul 15, 2025 - 10:56 MDT
This incident affected: Email, Calendar, & Collaboration (Employee Email, Student Gmail).