Class Registration Errors
Incident Report for Utah Valley University
Resolved
The class registration errors have been resolved. Please contact the Service Desk if you experience any more issues.
Posted Oct 20, 2020 - 17:30 MDT
Monitoring
A fix has been applied and users should no longer encounter web errors in the class registration system. We will continue to monitor class registration closely.
Posted Oct 20, 2020 - 16:36 MDT
Investigating
We are investigating reports that some users are encountering errors in the class registration system. Updates will be provided as we learn more.
Posted Oct 20, 2020 - 15:50 MDT
This incident affected: myUVU Services (myUVU Student Services).