Office 365 Office.com Outage
Incident Report for Utah Valley University
Resolved
Microsoft has announced that the issue is fully resolved.
Posted Nov 19, 2019 - 22:15 MST
Monitoring
Microsoft has applied a fix and things seem to be working. Please see status.office.com for more details.
Posted Nov 19, 2019 - 20:35 MST
Update
Microsoft has identified that users may experience access issues with some Office 365 products. Please see status.office.com for additional details.
Posted Nov 19, 2019 - 19:30 MST
Identified
Office.com is experiencing an outage affecting all of our Office 365 products. Microsoft is working on it. An update will be provided when we learn more.
Posted Nov 19, 2019 - 18:47 MST