Potential issue impacting access to Concurrent Enrollment student enrollment system
Incident Report for Utah Valley University
Resolved
The issue preventing access to the Concurrent Enrollment student enrollment system has been resolved. Please contact the Service Desk if you experience any further issues.
Posted Sep 04, 2024 - 15:57 MDT
Monitoring
A fix has been applied and Concurrent Enrollment registration should be working now. We will continue to monitor this service closely.
Posted Sep 04, 2024 - 10:54 MDT
Investigating
We are investigating reports of a potential issue preventing Concurrent Enrollment students from accessing the enrollment system. Updates will be provided as we learn more.
Posted Sep 04, 2024 - 09:35 MDT
This incident affected: myUVU Services (myUVU Student Services).