my.uvu.edu Outage
Incident Report for Utah Valley University
Resolved
The network outage affecting UVU services has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Sep 03, 2024 - 08:25 MDT
Monitoring
A fix has been applied and UVU services including my.uvu.edu should be available to all users. We will continue to monitor it closely.
Posted Sep 01, 2024 - 03:40 MDT
Identified
We have identified an network outage affecting several UVU services, including my.uvu.edu. Updates will be provided as we learn more.
Posted Sep 01, 2024 - 00:43 MDT
Investigating
We are investigating reports of a my.uvu.edu outage. Updates will be provided as we learn more.
Posted Aug 31, 2024 - 23:38 MDT
This incident affected: myUVU Services (myUVU General Services) and General IT Services.