Partial Phone System Outage
Incident Report for Utah Valley University
Resolved
The partial phone system outage affecting the Wasatch campus has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Dec 16, 2022 - 17:45 MST
Monitoring
A fix has been applied and the phone system should be available at Wasatch Campus. We will continue to monitor the phone system closely.
Posted Dec 16, 2022 - 16:06 MST
Identified
We have identified a partial outage affecting the phone system at Wasatch Campus. We are working with CenturyLink to resolve the issue. Updates will be provided as we learn more.
Posted Dec 16, 2022 - 09:06 MST
This incident affected: Email, Calendar, & Collaboration (Telephones).