Grouper Outage

Incident Report for Utah Valley University

Resolved

The Grouper outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Sep 15, 2025 - 08:38 MDT

Identified

We have identified an outage affecting Grouper services. Updates will be provided as we learn more.
Posted Sep 10, 2025 - 10:50 MDT
This incident affected: General IT Services.