Concur Employee Travel Outage
Incident Report for Utah Valley University
Resolved
This incident has been resolved.
Posted Jun 22, 2020 - 15:54 MDT
Monitoring
Concur has identified the issue and applied a fix. Please contact the Service Desk if you continue to experience issues accessing Concur.
Posted Jun 22, 2020 - 14:53 MDT
Identified
Concur is currently unavailable to manage employee travel. We are working with the vendor to resolve this issue. An update will be provided when we have more information.
Posted Jun 22, 2020 - 12:45 MDT
This incident affected: Software & Apps (Employee Software).