Wolverine Track unavailable
Incident Report for Utah Valley University
Resolved
Wolverine Track is now available. Please contact the Service Desk if you experience any issues.
Posted Jun 06, 2020 - 17:16 MDT
Identified
Wolverine Track is currently unavailable which may impact some people’s ability to register. We are working on resolving the issue. Updates will be given as we know more.
Posted Jun 06, 2020 - 17:03 MDT
This incident affected: myUVU Services (myUVU Student Services).