Microsoft Planner Loading Outage

Incident Report for Utah Valley University

Monitoring

The loading issue with Microsoft Planner is intermittent and users report that service is now available again. We will continue to monitor the service closely.
Posted Apr 03, 2026 - 15:47 MDT

Investigating

We are investigating reports of a service outage with Microsoft Planner affecting users' ability to load plans. Updates will be provided as we learn more.
Posted Apr 03, 2026 - 15:27 MDT
This incident affects: Software, Websites & Apps (Office 365).