Landis Phone Queues Outage

Incident Report for Utah Valley University

Update

Calls made to the Enterprise Service Desk, Financial Aid, and Admissions may fail due to an intermittent outage affecting Landis call queues.

For non-phone support from the Enterprise Service Desk, please use the support chat or submit a support ticket.

Financial aid may be emailed at financialaid@uvu.edu or via support ticket.

Admissions may be reached via live chat, via email at admissions@uvu.edu, or via support ticket.

For details from Landis, please see the Landis status page.
Posted Feb 10, 2026 - 08:50 MST

Update

Landis reports that the phone queues outage is intermittent, so calls made to the Enterprise Service Desk and other affected UVU call centers may continue to fail.
For non-phone support from the Enterprise Service Desk, please use the support chat or submit a support ticket.
For details from Landis, please see the Landis status page.
Posted Feb 10, 2026 - 08:33 MST

Identified

We have identified a Landis outage affecting UVU call center phone queues, including the Enterprise Service Desk. If you need support from the Enterprise Service Desk, please use the support chat or submit a support ticket.
For details from Landis, please see the Landis status page.
Updates will be provided as we learn more.
Posted Feb 10, 2026 - 08:07 MST
This incident affects: General IT Services.