Technical issues impacting UVU's aviation program at Provo Airport

Incident Report for Utah Valley University

Resolved

The UVU Aviation outage affecting some services related to the aviation program has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Jan 28, 2025 - 14:50 MST

Monitoring

A fix has been applied and UVU's aviation program should no longer be impacted by the technical issues. We will continue to monitor the situation closely.
Posted Jan 28, 2025 - 08:36 MST

Investigating

We are investigating reports of technical issues with computers impacting some services with the UVU aviation program at Provo airport. Updates will be provided as we learn more.
Posted Jan 28, 2025 - 08:12 MST
This incident affected: General IT Services.