UVU Registration Partial Outage
Incident Report for Utah Valley University
Resolved
The UVU registration partial outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Nov 04, 2022 - 13:51 MDT
Identified
We have identified a partial registration system outage affecting all students using the Schedule Wizard and the Add/Drop System. Details can be found on the 'Registration & Academics' My UVU page. Updates will be provided as we learn more.
Posted Oct 24, 2022 - 14:47 MDT
This incident affected: myUVU Services (myUVU Student Services) and Registration and Planning (Class Registration).