Get email notifications whenever Utah Valley University creates, updates or resolves an incident.
Get text message notifications whenever Utah Valley University creates or resolves an incident.
Get webhook notifications whenever Utah Valley University creates an incident, updates an incident, resolves an incident or changes a component status.
System maintenance is scheduled for Saturday, August 31st, from 7:00 AM to 9:30 AM. Some services in myUVU will be unavailable. Canvas is expected to remain available.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 31, 2024 - 07:00 MDT
Scheduled
The following services may be unavailable during this scheduled maintenance: Student Services - Registration and Planning Services - My Academics Services such as Wolverine Track, Grades, Class List, Degree Information Services - Paying For My Education Services Employee Services - Banner Services - Payroll and Timeclock Faculty Services - Banner Faculty Services - My Classes Services Advisor Services - Advisor Dashboard - Banner Advisor Services - Advisor Course Information
Posted Aug 29, 2024 - 10:40 MDT
This scheduled maintenance affected: myUVU Services (myUVU General Services, myUVU Student Services, myUVU Employee Services).