Partial Mobile App Outage

Incident Report for Utah Valley University

Identified

To access the UVU student mobile app, newly admitted students can enroll through my.uvu.edu. After enrolling, they will then be able to access the mobile app.
Posted May 08, 2026 - 15:10 MDT

Investigating

We are investigating reports that newly admitted students cannot access UVU Mobile App. Updates will be provided as we learn more.
Posted May 08, 2026 - 14:38 MDT
This incident affects: myUVU Services (myUVU Student Services).