Degraded Performance of Various Atlassian Products

Incident Report for Utah Valley University

Resolved

The Atlassian products performance issue has been resolved. Please contact the Service Desk if you experience any further issues.
Posted Dec 15, 2025 - 14:28 MST

Monitoring

Atlassian reports a fix has been applied and all affected Atlassian products should be available. We will continue to monitor Atlassian product performance closely.
Posted Dec 15, 2025 - 12:33 MST

Identified

We have identified degraded performance of various Atlassian products, including Jira, Confluence, and other Atlassian services caused by the vendor. This may impact the ability to create Jira tickets or request assistance from the Enterprise Service Desk online. Should you require immediate assistance, please contact the Service Desk via phone at 801.863.8888.
Posted Dec 15, 2025 - 09:30 MST
This incident affected: Email, Calendar, & Collaboration (Atlassian) and General IT Services.