CS, LC Networking Outage

Incident Report for Utah Valley University

Resolved

The networking outage affecting the CS and LC buildings has been resolved. Please contact the Service Desk if you experience any more issues.
Posted May 29, 2026 - 08:56 MDT

Monitoring

A fix has been applied and networking should be available to all users. We will continue to monitor the network status closely.
Posted May 28, 2026 - 13:13 MDT

Investigating

We are investigating reports of a networking outage in the CS - Computer Science and LC - Losee Center buildings. Updates will be provided as we learn more.
Posted May 28, 2026 - 09:19 MDT
This incident affected: Network & Wireless (Wireless Network, Wired Network).