Degraded Canvas Performance
Incident Report for Utah Valley University
Resolved
The issue affecting load times when accessing Canvas has been resolved. Please contact the Service Desk if you experience any further issues.
Posted Aug 26, 2024 - 14:05 MDT
Identified
We have identified an issue affecting load times when accessing Canvas. Updates will be provided as we learn more.
Posted Aug 26, 2024 - 11:06 MDT
This incident affected: Teaching, Learning, & Classrooms (Canvas).