Citrix virtual desktop and applications partially unavailable
Incident Report for Utah Valley University
Resolved
Access to Citrix virtual desktops and applications at virtuallabex.uvu.edu has been restored and verified functional from on and off campus. If you are still having any technical issues please contact the Service Desk.
Posted Apr 21, 2020 - 17:05 MDT
Monitoring
Access to Citrix virtual desktops and applications at virtuallabex.uvu.edu has been restored. If you are still having any technical issues please contact the Service Desk.
Posted Apr 21, 2020 - 16:37 MDT
Identified
Users are encountering issues trying to access Citrix virtual desktops and applications at virtuallabex.uvu.edu. As a workaround you can access these services over the campus VPN at virtuallab.uvu.edu. Please contact the Service Desk if you need help with the workaround.
Posted Apr 21, 2020 - 16:04 MDT
This incident affected: General IT Services.