myUVU Enrollment Task Outage
Incident Report for Utah Valley University
Resolved
This incident has been resolved. Please contact the Service Desk if you continue to experience issues.
Posted Apr 26, 2021 - 17:38 MDT
Monitoring
A fix has been applied and all services appear to be available again. Please contact the Service Desk if you continue to experience issues.
Posted Apr 26, 2021 - 16:47 MDT
Identified
We have identified a myUVU outage affecting enrollment task information for all semesters. Updates will be provided as we learn more.
Posted Apr 26, 2021 - 16:10 MDT
This incident affected: myUVU Services (myUVU General Services, myUVU Student Services, myUVU Employee Services).