HB Building Power Outage
Incident Report for Utah Valley University
Resolved
The HB building power outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Nov 07, 2022 - 09:28 MST
Monitoring
A fix has been applied and HB building power and Networking should be available. We will continue to monitor HB building power closely.
Posted Nov 07, 2022 - 07:09 MST
Investigating
We are investigating reports of a power outage affecting the HB building networking. Updates will be provided as we learn more.
Posted Nov 07, 2022 - 06:50 MST
This incident affected: Campus Services (Power).