PeopleAdmin and uvu.jobs website unavailable from campus network
Incident Report for Utah Valley University
Resolved
A fix has been applied to uvu.jobs and PeopleAdmin. Please contact the Service Desk if you are experiencing further issues.
Posted Mar 04, 2021 - 19:03 MST
Monitoring
A fix has been applied and uvu.jobs and PeopleAdmin should be available to users from all locations now. We will continue to monitor these services closely.
Posted Mar 04, 2021 - 17:15 MST
Identified
We have identified an outage affecting access from the UVU network to the uvu.jobs website and PeopleAdmin. PeopleAdmin and uvu.jobs are still available from non-UVU networks. Updates will be provided as we learn more.
Posted Mar 04, 2021 - 16:07 MST
This incident affected: myUVU Services (myUVU Employee Services).