Banner Application Navigator issue
Incident Report for Utah Valley University
Resolved
Banner Application Navigator is now fully functional. If you are still experiencing issues please contact the Service Desk.
Posted Apr 28, 2020 - 11:16 MDT
Monitoring
Banner Application Navigator is now fully functional. If you are still experiencing issues please contact the Service Desk.
Posted Apr 28, 2020 - 10:53 MDT
Investigating
Banner Application Navigator is experiencing slow load times and session failures. We are currently looking into the issue and will provide an update as soon as we know more.
Posted Apr 28, 2020 - 10:25 MDT
This incident affected: Business Applications & Reporting (Banner Application Navigator).