Power Outage at Canyon Park Building L
Incident Report for Utah Valley University
Resolved
This incident has been resolved.
Posted Jan 17, 2020 - 09:11 MST
Monitoring
Power has been restored to Canyon Park Building L. We are continuing to monitor the situation. Please contact the Service Desk if you continue to experience any issues.
Posted Jan 17, 2020 - 08:46 MST
Investigating
Canyon Park Building L is experiencing a power outage due to utility power outages in the area. Our utility provider is aware and is working to restore power.
Posted Jan 17, 2020 - 08:10 MST