GPA Calc Issue in Wolverine Track
Incident Report for Utah Valley University
Resolved
This incident has been resolved. Please contact the Service Desk if you continue to experience issues.
Posted May 28, 2020 - 18:29 MDT
Monitoring
An issue has be resolved with GPA Calc in Wolverine Track. If you continue to experience issues please contact the Service Desk.
Posted May 28, 2020 - 17:54 MDT
This incident affected: Software & Apps (Student Software).