PeopleAdmin/uvu.jobs degraded performance
Incident Report for Utah Valley University
Resolved
The PeopleAdmin/UVU.jobs speed issue has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Sep 14, 2020 - 20:00 MDT
Monitoring
A fix has been applied and PeopleAdmin/uvu.jobs should be back to normal speeds. We will continue to monitor PeopleAdmin/uvu.jobs closely.
Posted Sep 14, 2020 - 19:41 MDT
Investigating
We are investigating reports that PeopleAdmin/uvu.jobs websites are running slowly. Updates will be provided as we learn more.
Posted Sep 14, 2020 - 17:49 MDT