Canvas Outage
Incident Report for Utah Valley University
Resolved
The Canvas outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Sep 21, 2022 - 14:44 MDT
Monitoring
A fix has been applied and Canvas should be available for all users. We will continue to monitor Canvas closely.
Posted Sep 21, 2022 - 12:52 MDT
Investigating
We are investigating reports of a Canvas outage that is presenting load errors to users. Updates will be provided as we learn more.
Posted Sep 21, 2022 - 12:22 MDT
This incident affected: Teaching, Learning, & Classrooms (Canvas).