Canvas Outage
Incident Report for Utah Valley University
Resolved
The Canvas outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Mar 03, 2021 - 16:22 MST
Monitoring
A fix has been applied and Canvas should be available all users. We will continue to monitor Canvas closely.
Posted Mar 03, 2021 - 15:23 MST
Identified
We have identified a Canvas outage affecting all users. Updates will be provided as we learn more.
Posted Mar 03, 2021 - 14:42 MST
This incident affected: Teaching, Learning, & Classrooms (Canvas).