myUVU first time login outage More...
Incident Report for Utah Valley University
Resolved
The myUVU outage affecting first time logins for new students and staff has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Sep 18, 2020 - 17:29 MDT
Identified
We have identified the issue affecting first time login to myUVU for new students and staff and are working on a fix. Updates will be provided as we learn more.
Posted Sep 18, 2020 - 12:26 MDT
Investigating
We are investigating reports that some new students and employees are unable to conduct their first time login to myUVU. Updates will be provided as we learn more.
Posted Sep 17, 2020 - 11:18 MDT
This incident affected: Software, Websites & Apps (myUVU).